Ibexa DXP Discussions

Community discussion forum for developers working with Ibexa DXP

[Update 2.2][ezplatform-ee] Content edit interface broken

I updated to 2.2 from 2.1.1 (on ezplatform-ee) and after a few minor adjustments everything works well, except the content edit interface which is not displayed correctly anymore:

  • all fields are rendered with default html inputs without any style/function override (see per screenshot below)
  • yet there is no js error, no error whatsoever in symfony or ez logs, and the drafts are created/saved/published without problem.

I thought it might be because of the new parameters for the admin design and I’ve been investigating the problem and nothing can fix it. I tried to disable/enable standard design override of kernel templates, I changed my whole design and siteaccess groups configuration (in case it was linked to a wrong merging of config as per https://ezcommunity.slack.com/archives/C3YFR5ZM4/p1530274452000244).

Does anyone have the same problem? Am I missing something that should be obvious?

2 Likes

The problem is clearly that for all the fields, there seem to be no specific override. When I take a look at my my rendering graph, the form_div_layout.html.twig (symfony default rendering) is used for every field!

Troubleshooting led me there: on the ezsystems/ezplatform-admin-ui/src/bundle/Resources/views/content/content_edit/content_edit_base.html.twig, the form theme is to be overriden using the admin_ui_config.contentEditFormTemplates parameter, which for me is empty (cf. following screenshot displaying the content of my admin_ui_config variable directly in twig).

S%C3%A9lection_008

So the problem was indeed a wrong merging of configurations (see link in the original post) and can be diagnosed/fixed as following : if you have overriden any of the variables present in my screenshot in your ezpublish.yml in a global or siteaccess scope (for me it was the image_variations in global), other variables only defined elsewhere (for me in default blocks in the vendors) will be wiped, purely and simply. While waiting for eZ for a fix, you have to check that your variables are overriden at the same level if you want the one you override to not break the others (yes, it sucks!).

Have you tried to disable this setting?

ez_platform_standard_design:
    override_kernel_templates: false

We’ve discovered that for some setups automatic overriding Kernel (core) templates can lead to unexpected results. However disabling that override solved all of the issues discovered when testing.

@alongosz I can’t speak for @amval, but I am also having this problem since upgrading to 2.2, and setting override_kernel_templates to false did not fix it. Anything else you can recommend trying?

I tried with both the option enabled and disabled, and it didn’t change anything unfortunately. Only rewriting the full block of settings fixed it.

Hi,

Facing the same issue here

Salut.

Since yesterday I no longer have any style on the content editing forms.
All the rest of the admin works normally.

I have not found any mistakes anywhere. (php logs, ez, browser console…)

The problem is happening on my dev env.
I can’t reproduce the problem on my colleagues’ workstations or in preprod.

As for @jxn playing with ez_platform_standard_design.override_kernel_templates has no impact.

/app/config/ezplatform.yml

ez_platform_standard_design:
    override_kernel_templates: false

Indeed, it’s since I fixed the site access for the page_builder for my multisite.
I just deleted this part of my conf

ezpublish:
  system:
#    admin_1:
#        page_builder:
#            siteaccess_list: ['site_1']
#    admin_2:
#        page_builder:
#            siteaccess_list: ['site_2']

But as a result the page_builder no longer works…

I will have to understand how the settings work in eZ…
Are changes planned with 2.3?

See : https://jira.ez.no/browse/EZP-29528

I’m still facing the same problem.
Did the patch solve the issue for the OP and other posters?
I’m running ezsystems/ezplatform-admin-ui 1.3.2

The only thing that works for me is applying the configuration in the global namespace.

global:
      admin_ui_forms:
        content_edit_form_templates:
        - { template: '@ezdesign/content/form_fields.html.twig', priority: 0 }

Any other ideas?