Ibexa DXP Discussions

Community discussion forum for developers working with Ibexa DXP

Cannot access to the admin panel with the default admin user

After installation and configuration, I can’t access to the admin panel with the default admin user : admin/publish.
When I check the log file, I can see that the user was authenticated successfully but when redirecting to the dasbord page, it seems like the token was lost so anonymous token is populated to tokenstorage and I’m always redirect to login page.

I user default configuration of ez platform.

Could anyone help please?

Hello @mnorotiana,

There was a known issue with accessing Admin panel when an instance was running on non-standard port (e.g. 8000 or 8080) due to 3rd party bug. Do you run your instance in such way?

It has been fixed recently, so maybe try upgrading eZ Platform and/or just clearing cookies.

Hello @alongosz,
Thank you for your response. Unfortunately, even if I use 8080 as port, It doesn’t fix the issue :frowning:

PS : I saw that multiple session file is generated after login. May be, it’s the reason why I can’t access to the admin panel because the last session file doesn’t contain the user.

The point was actually to use 80 if you were using non-standard one :slight_smile:
It seems what you’re facing is a different issue.
@mnorotiana what version of eZ Platform are you using?

Hello @alongosz,
I tried both cases, using standard and non-standard but the result is the same.
I’m using eZ Platform 2.5.
Thanks for your help

I’ve just installed fresh eZ Platform v2.5.9. I cannot reproduce the issue.
Have you tried clearing browser cookies?

Unfortunately, yes.
I installed to another server, my server test, and I can connect the user successfully.
And when I investigate, and compare the 2 servers, I can see that instead of having just one session file, I have 3 in the first server where I got the issue:

  • the first with the user token
  • the second without the user but with target_path (the dashboard url)
  • the third with _csrf/authenticate attribute


This might be then something specific to that server configuration. It’s hard to guess what.
What kind of server is this (and what version)? Nginx, Apache, Platform.sh, Symfony Cloud, local PHP server or something else?

I’m working with Apache/2.4.6 (CentOS) - PHP/7.2.21
I tried with the built in symfony server as well.

I’m sorry, but I haven’t been able to reproduce this issue. However if this occurs both with Apache and Symfony server, the issue might be in stored user data, not the configuration. Unsure.