Ibexa DXP Discussions

Community discussion forum for developers working with Ibexa DXP

2.5.5 upgrade bonanza?


I am trying to get 2.5.5 up and running, but it seem I have to install som earlier release first; the admin UI is missing. The frontend seems to be working.

Do I have to install an earlier version (eg. 2.0.0) and then upgrade my way to 2.5.5, or is the admin UI hidden in some secret part of the universe.

We are running eZ Publish, but would really want to migrate to Platform…

Regards, Atle

What url are you trying to access?
AFAIK, should be /admin for the admin UI

Yes, /admin.

Regards, Atle

Hi @Nesrene!

You don’t need to install eZ Platform 2.0.0 and update after. You can start directly with eZ Platform 2.5.5.

Did you try to install eZ Platform 2.5.5 from scratch or is it a migration from eZ Publish?

2.5.5 from scratch. No migration.

First we have to get Platform up and running, then we can start migrating :slight_smile:

Regards, Atle

In the web-folder, these are the only files present:

-rw-rw-r-- 1 www-data www-data 967 Sep 6 22:09 app_dev.php
-rw-rw-r-- 1 www-data www-data 3127 Sep 6 22:09 app.php
drwxrwxr-x 5 www-data www-data 4096 Sep 6 22:13 assets
drwxrwxr-x 2 www-data www-data 4096 Sep 6 22:12 bundles
-rw-rw-r-- 1 www-data www-data 1740 Sep 6 14:10 .htaccess

Is something missing? This is still out of the box, I have done nothing else than install.

Regards, Atle

Hi, When you say installed… have you at all ran composer? That is the one that resolves all the dependencies (in case you did not know)
Have you followed the installation docs available at https://doc.ezplatform.com/en/latest/getting_started/install_ez_platform?

Yes, I have done it the composer way also, in addition to the download option. And yes, I followed that recepie.

I really do not know where to look for the answer(s)…

Regards, Atle

It migth be something fubar with the Apache config? Here’s the config-file: http://eye-on-everything.org/vhost.txt - well, there is something wrong with the Apache config.

The site for platform is http://eye-on-sports.org/ - as one can see it’s not working at all. When it “worked” I used the .htaccess option, but then the admin part did not.

Regards, Atle

I would recommend that you kick things off by making sure the installation is working, not adding more parameters to this with Apache config ++. You can do this simply by testing out with using PHP built in web server. This makes sure you at least isolate the problem here. If you are not able to progress i suggest you clearly indicate the steps you have taken and hopefully that makes it more clear to others as well. Which php version are you on btw? Good luck

1 Like

Ok, I started the PHP-server (php bin/console server:run eye-on-sports.org:443) and it works. So it must be an issue with Apache…

Where can I find a working Apache config to use as template?

Regards, Atle

Your vhost looks weird. At one place you specify index.php, on the other its app.php, so definitely not correct.
Check this example: https://github.com/netgen/media-site/blob/master/doc/apache2/netgen-site-vhost.conf

Well, that had nothing to do with the malfunction. This conf works, and it worked with index.php as DirectoryIndex.

<VirtualHost *:80>
#ServerAlias *.localhost
DirectoryIndex app.php

# Set default timeout to 90s, and max upload to 48mb
# TimeOut 90
# LimitRequestBody 50331648

<Directory <path to directory>>
    Options FollowSymLinks
    AllowOverride None
    # Depending on your global Apache settings, you may need to comment this:
    Require all granted

ErrorLog <path to logfile>
LogLevel error
CustomLog <path to logfile> combined

As we require mod_rewrite this is on purpose not placed in a block

RewriteEngine On

# Environment.
# Possible values: "prod" and "dev" out-of-the-box, other values possible with proper configuration
# Defaults to "prod" if omitted. If Apache complains about this line and you can't install `mod_setenvif` then
# comment out "%{ENV:SYMFONY_ENV}" line below, and comment this out or set via: SetEnv SYMFONY_ENV "prod"
SetEnvIf Request_URI ".*" SYMFONY_ENV=prod

# Sets the HTTP_AUTHORIZATION header sometimes removed by Apache
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

# Disable .php(3) and other executable extensions in the var directory
RewriteRule ^var/.*(?i)\.(php3?|phar|phtml|sh|exe|pl|bin)$ - [F]

# Access to repository images in single server setup
RewriteRule ^/var/([^/]+/)?storage/images(-versioned)?/.* - [L]

# Makes it possible to place your favicon and robots.txt at the root of your public folder
RewriteRule ^/favicon\.ico - [L]
RewriteRule ^/robots\.txt - [L]

# The following rules are needed to correctly display bundle and project assets
RewriteRule ^/bundles/ - [L]
RewriteRule ^/assets/ - [L]

# Additional Assetic rules for environments different from dev,
# remember to run php bin/console assetic:dump --env=prod
RewriteCond %{ENV:SYMFONY_ENV} !^(dev)
RewriteRule ^/(css|js|fonts?)/.*\.(css|js|otf|eot|ttf|svg|woff) - [L]

RewriteRule .* /app.php

Regards, Atle